Skip to content

Install SickGear [6] macOS

SickGear edited this page Feb 25, 2023 · 1 revision

SickGear Wiki: Home | Reporting Issues | Frequently Answered Questions | > Install Guides <

OS 11: SickGear Install Guide (tested macOS Big Sur 11.0.1)


Installation

This guide was made using macOS Big Sur 11.0.1 but may help with other releases.

Tip: Enter the following in a Terminal to show hidden files and sub directories from the root directory of Finder

% defaults write com.apple.finder AppleShowAllFiles -bool TRUE;killall Finder

Note for older systems; all of the following steps work using python (2.7) instead of python3

  1. Open a Terminal

  2. Verify available Python 3. If no success here, install Python3.7.1+

    % python3 -V
    Python 3.8.2
    
  3. Verify and install git. Agree if asked to install command line developer tools for git. If not asked, install git

    % git version
    git version 2.24.3 (Apple Git-128)
    
  4. Check if Package Installer Python (pip) is available.
    If result is "No module named pip", then continue at step 5, otherwise skip to step 6...

    % python3 -m pip --version
    
  5. Fetch and install Package Installer Python (pip)

    % cd ~ 
    % curl https://bootstrap.pypa.io/get-pip.py -o get-pip.py
    % python3 get-pip.py
    

    Check pip installed succesfully

    % python3 -m pip --version
    pip 20.3.1 ... (python 3.8)
    
  6. Create SickGear app and data folders

    % sudo mkdir -p /opt/sickgear/app
    % sudo mkdir -p /opt/sickgear/data
    
  7. Fetch the app. Note; the logged in user here is user1, change user1 in accordance with your set up

    % sudo git clone https://github.com/SickGear/SickGear.git /opt/sickgear/app/
    % sudo chown -R user1 /opt/sickgear
    
  8. Install Python dependancies for SickGear

    % cd /opt/sickgear/app
    % python3 -m pip install --user -r requirements.txt
    % python3 -m pip install --user -r recommended.txt
    
  9. Set a locale with UTF-8, (you may prefer a different locale -a than the following examples)
    System locale must have utf-8 to support show names like "Les Misérables"
    for en_GB ...

    % echo -e "export LC_ALL=en_GB.UTF-8\nexport LANG=en_GB.UTF-8" >> ~/.bash_profile && . ~/.bash_profile
    

    for en_US ...

    % echo -e "export LC_ALL=en_US.UTF-8\nexport LANG=en_US.UTF-8" >> ~/.bash_profile && . ~/.bash_profile
    
  10. Run Sickgear

    % python3 ./sickgear.py
    

All done, you can access SickGear at http://localhost:8081

Note: if installing unrar, make sure to notarize the binary to make it available to SickGear at runtime, e.g. in Finder; ctrl-click the binary then "Open" -> "Open"


Launch Agent (launchd)

Goal: Create a LaunchAgent plist file (an xml formatted pure text file, not rich text)

  1. a) Open a Terminal to run the vi text editor, then enter

    % vi /Library/LaunchAgents/com.sickgear.sickgear.plist
    

    b) Insert content; press "i", observe -- INSERT -- in the status line, then copy/paste the following...

    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
      <key>Label</key>
      <string>SickGear</string>
      <key>ProgramArguments</key>
      <array>
        <string>/usr/bin/python3</string>
        <string>/opt/sickgear/app/sickgear.py</string>
        <string>--datadir</string>
        <string>/opt/sickgear/data/</string>
      </array>
      <key>RunAtLoad</key>
      <true/>
    </dict>
    </plist>
    

    c) Save file; press "Esc" then ":" for the vi input cmdline, then enter "wq" to write file and quit

  2. Verify that the created plist is correct

    % plutil /Library/LaunchAgents/com.sickgear.sickgear.plist
    /Library/LaunchAgents/com.sickgear.sickgear.plist: OK
    
  3. Launch - don't worry if notified that SickGear is already running or error 5, it will still work on restart

    % launchctl load /Library/LaunchAgents/com.sickgear.sickgear.plist
    
  4. The service can be verified using

    % launchctl list SickGear
    

Screenshot

SickGear About page in macOS 11

Clone this wiki locally