Skip to content

Commit

Permalink
Replace cmake-utils eclass with cmake eclass
Browse files Browse the repository at this point in the history
See gentoo/gentoo@0ebbf56

Also update affected ebuilds that weren't yet on EAPI 7 to EAPI 7 because cmake.eclass only supports EAPI 7
  • Loading branch information
simonvanderveldt committed Sep 6, 2020
1 parent 07ba702 commit 32ee5cb
Show file tree
Hide file tree
Showing 7 changed files with 22 additions and 22 deletions.
8 changes: 4 additions & 4 deletions media-plugins/artyfx/artyfx-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2017 Gentoo Foundation
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
EAPI=7

inherit cmake-utils
inherit cmake

DESCRIPTION="Plugin bundle of artistic real-time audio effects"
HOMEPAGE="http://openavproductions.com/artyfx"
Expand Down Expand Up @@ -33,5 +33,5 @@ src_configure() {
-DBUILD_SSE="$(usex cpu_flags_x86_sse ON OFF)"
-DBUILD_BENCH=OFF
)
cmake-utils_src_configure
cmake_src_configure
}
6 changes: 3 additions & 3 deletions media-plugins/fabla/fabla-1.9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2017 Gentoo Foundation
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
EAPI=7

inherit cmake-utils
inherit cmake

DESCRIPTION="LV2 drum sampler plugin"
HOMEPAGE="http://openavproductions.com/fabla"
Expand Down
8 changes: 4 additions & 4 deletions media-plugins/fabla/fabla-2.9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2017 Gentoo Foundation
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
EAPI=7

inherit cmake-utils git-r3
inherit cmake git-r3

DESCRIPTION="LV2 drum sampler plugin"
HOMEPAGE="http://openavproductions.com/fabla2"
Expand All @@ -26,5 +26,5 @@ src_configure() {
local mycmakeargs=(
-DBUILD_GUI="$(usex X ON OFF)"
)
cmake-utils_src_configure
cmake_src_configure
}
6 changes: 3 additions & 3 deletions media-plugins/sorcer/sorcer-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2017 Gentoo Foundation
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
EAPI=7

inherit cmake-utils
inherit cmake

DESCRIPTION="Polyphonic wavetable synth LV2 plugin"
HOMEPAGE="http://openavproductions.com/sorcer"
Expand Down
4 changes: 2 additions & 2 deletions media-sound/luppp/luppp-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake-utils
inherit cmake

DESCRIPTION="Live performance looping tool"
HOMEPAGE="http://openavproductions.com/luppp"
Expand Down
6 changes: 3 additions & 3 deletions media-sound/sc3-plugins/sc3-plugins-3.10.0.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
EAPI=7

inherit git-r3 cmake-utils
inherit git-r3 cmake

DESCRIPTION="Third party plugins for SuperCollider"
HOMEPAGE="https://github.com/supercollider/sc3-plugins"
Expand Down Expand Up @@ -37,5 +37,5 @@ src_configure() {
-DSUPERNOVA=ON
)

cmake-utils_src_configure
cmake_src_configure
}
6 changes: 3 additions & 3 deletions media-sound/sc3-plugins/sc3-plugins-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
EAPI=7

inherit git-r3 cmake-utils
inherit git-r3 cmake

DESCRIPTION="Third party plugins for SuperCollider"
HOMEPAGE="https://github.com/supercollider/sc3-plugins"
Expand Down Expand Up @@ -33,5 +33,5 @@ src_configure() {
-DSUPERNOVA=ON
)

cmake-utils_src_configure
cmake_src_configure
}

0 comments on commit 32ee5cb

Please sign in to comment.