Skip to content

Commit

Permalink
media-plugins/sorcer: Fix compilation with GCC 9
Browse files Browse the repository at this point in the history
  • Loading branch information
simonvanderveldt committed Sep 6, 2020
1 parent 6307a22 commit 07ba702
Show file tree
Hide file tree
Showing 2 changed files with 36 additions and 0 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
From 872c11e1f289b43a50a7aa1eed550fac59a8957c Mon Sep 17 00:00:00 2001
From: Simon van der Veldt <[email protected]>
Date: Tue, 18 Aug 2020 17:43:03 +0200
Subject: [PATCH] Remove leading underscore to fix compilation with gcc-9.3.0

---
gui/sorcer_ui.cxx | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/gui/sorcer_ui.cxx b/gui/sorcer_ui.cxx
index 60edbe4..f0afd06 100644
--- a/gui/sorcer_ui.cxx
+++ b/gui/sorcer_ui.cxx
@@ -37,14 +37,14 @@ using namespace std;

typedef struct {
SorcerUI* widget;
-
+
float sidechainAmp;
-
+
LV2UI_Write_Function write_function;
LV2UI_Controller controller;
} SorcerGUI;

-static LV2UI_Handle instantiate(const struct _LV2UI_Descriptor * descriptor,
+static LV2UI_Handle instantiate(const struct LV2UI_Descriptor * descriptor,
const char * plugin_uri,
const char * bundle_path,
LV2UI_Write_Function write_function,
--
2.26.2

2 changes: 2 additions & 0 deletions media-plugins/sorcer/sorcer-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -26,3 +26,5 @@ RDEPEND="media-libs/lv2
dev-libs/boost
>=x11-libs/ntk-1.3.1000"
DEPEND="${RDEPEND}"

PATCHES="${FILESDIR}/${PN}-gcc-9-remove-leading-underscore.patch"

0 comments on commit 07ba702

Please sign in to comment.