Skip to content

Commit

Permalink
trying to get github actions building debian packages
Browse files Browse the repository at this point in the history
  • Loading branch information
stew committed Oct 16, 2024
1 parent 57d1680 commit 7d83a89
Show file tree
Hide file tree
Showing 9 changed files with 40 additions and 18 deletions.
14 changes: 14 additions & 0 deletions .github/workflows/release.yaml
Original file line number Diff line number Diff line change
@@ -0,0 +1,14 @@
name: release

on: push

jobs:
build-debs:
runs-on: ubuntu-latest
steps:
- uses: actions/checkout@v4
- uses: jtdor/build-deb-action@v1
env:
DEB_BUILD_OPTIONS: noautodbgsym
with:
buildpackage-opts: --build=binary --no-sign
5 changes: 5 additions & 0 deletions .gitignore
Original file line number Diff line number Diff line change
@@ -1,7 +1,12 @@
build
debian/unisonweb
debian/files
.#*
*~
*.debhelper*
*-stamp
.envrc
.unisonHistory



Empty file removed .unisonHistory
Empty file.
10 changes: 8 additions & 2 deletions debian/changelog
Original file line number Diff line number Diff line change
@@ -1,7 +1,13 @@
unisonweb (0.5.20~trunk+2024051601) UNRELEASED; urgency=medium
unisonweb (0.5.28~trunk+2024101501) UNRELEASED; urgency=low

* adding github action

* new version
-- Stew O'Connor <[email protected]> Tue, 15 Oct 2024 16:29:14 -0700

unisonweb (0.5.20~trunk+2024051601) UNRELEASED; urgency=medium

* new version
n
-- Stew O'Connor <[email protected]> Thu, 16 May 2024 10:52:50 -0700

unisonweb (0.5.20~trunk+2024041702) unstable; urgency=low
Expand Down
2 changes: 1 addition & 1 deletion debian/control
Original file line number Diff line number Diff line change
Expand Up @@ -12,6 +12,6 @@ Package: unisonweb
Architecture: any
Section: devel
Multi-Arch: foreign
Depends: ${misc:Depends}, ${shlibs:Depends}, libncurses6, libtinfo6, less, locales
Depends: ${misc:Depends}, ${shlibs:Depends}, libncurses6, libtinfo6, less, locales, racket, racket-doc
Description: A functional programming language

2 changes: 0 additions & 2 deletions debian/files

This file was deleted.

16 changes: 10 additions & 6 deletions debian/rules
Original file line number Diff line number Diff line change
@@ -1,18 +1,22 @@
#!/usr/bin/make -f

# UNISON_RELEASE:=https://github.com/unisonweb/unison/releases/download/trunk-build/ucm-linux.tar.gz
# UNISON_RELEASE:=https://github.com/unisonweb/unison/releases/download/jit-release-build/ucm-linux.tar.gz
UNISON_RELEASE:=https://github.com/unisonweb/unison/releases/download/trunk-build/ucm-linux.tar.gz
UNISON_RELEASE=https://github.com/unisonweb/unison/releases/download/trunk-build/ucm-linux-x64.tar.gz
%:
dh $@

override_dh_clean:
rm -r build
dh_clean
rm -rf build

override_dh_auto_build:
mkdir -p build
wget "${UNISON_RELEASE}" -O- | tar xvzf - -C build
wget ${UNISON_RELEASE} -O- | tar xvzf - -C build


override_dh_install:
dh_install

override_dh_strip:
echo

override_dh_shlibdeps:
dh_shlibdeps -Xunison-runtime
6 changes: 2 additions & 4 deletions debian/unisonweb.postinst
Original file line number Diff line number Diff line change
Expand Up @@ -4,10 +4,8 @@ set -eu

if [ "$1" = 'configure' ]; then
if raco pkg show -u | grep -q unison ; then
# i'm surprised we don't want update -stew
# raco pkg update --auto /usr/lib/unisonweb/racket/unison.zip
raco pkg install --auto /usr/lib/unisonweb/racket/unison.zip
raco pkg update --auto /usr/lib/unisonweb/racket/unison.zip
else
raco pkg install --auto /usr/lib/unisonweb/racket/unison.zip
raco pkg install --no-docs --auto /usr/lib/unisonweb/racket/unison.zip
fi
fi
3 changes: 0 additions & 3 deletions debian/unisonweb.substvars

This file was deleted.

0 comments on commit 7d83a89

Please sign in to comment.