-
Notifications
You must be signed in to change notification settings - Fork 23
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
.github/workflows/build: use pengutronix-hosted runner
This is a backport of the workflow file on master adapted to build for kirkstone. Signed-off-by: Leonard Göhrs <[email protected]>
- Loading branch information
Showing
2 changed files
with
74 additions
and
52 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,74 @@ | ||
name: build (kirkstone) | ||
|
||
on: | ||
push: {} | ||
pull_request: {} | ||
# allow rebuilding without a push | ||
workflow_dispatch: {} | ||
|
||
jobs: | ||
build: | ||
name: build | ||
# run on self-hosted runner for the main repo or if vars.BUILD_RUNS_ON is set | ||
runs-on: >- | ||
${{ | ||
(vars.BUILD_RUNS_ON != '' && fromJSON(vars.BUILD_RUNS_ON)) || | ||
(github.repository == 'pengutronix/meta-ptx' && fromJSON('["self-hosted", "forrest", "build"]')) || | ||
'ubuntu-20.04' | ||
}} | ||
# abort if it seems that we're rebuilding too much | ||
timeout-minutes: 120 | ||
steps: | ||
- name: Install required packages | ||
run: | | ||
sudo apt-get -q -y --no-install-recommends install diffstat python3-distutils | ||
- name: Checkout | ||
uses: actions/checkout@v4 | ||
with: | ||
path: meta-ptx | ||
- name: Clone poky | ||
run: git clone --shared --reference-if-able /srv/shared-git/poky.git -b kirkstone https://github.com/yoctoproject/poky.git | ||
- name: Clone meta-openembedded | ||
run: git clone --shared --reference-if-able /srv/shared-git/meta-openembedded.git -b kirkstone https://github.com/openembedded/meta-openembedded.git | ||
- name: Initialize build directory | ||
run: | | ||
source poky/oe-init-build-env build | ||
bitbake-layers add-layer ../meta-openembedded/meta-oe | ||
bitbake-layers add-layer ../meta-ptx | ||
if [ -f ~/.yocto/auto.conf ]; then | ||
cp ~/.yocto/auto.conf conf/ | ||
else | ||
echo 'SSTATE_MIRRORS = "file://.* https://github-runner.pengutronix.de/sstate-cache/PATH"' >> conf/auto.conf | ||
echo 'BB_SIGNATURE_HANDLER = "OEBasicHash"' >> conf/auto.conf | ||
echo 'BB_HASHSERVE = ""' >> conf/auto.conf | ||
echo 'OPKGBUILDCMD = "opkg-build -Z gzip -a -1n"' >> conf/auto.conf | ||
echo 'INHERIT += "rm_work"' >> conf/auto.conf | ||
fi | ||
echo 'DISTRO_FEATURES:remove = "alsa bluetooth usbgadget usbhost wifi nfs zeroconf pci 3g nfc x11 opengl ptest wayland vulkan"' >> conf/local.conf | ||
- name: Build barebox | ||
run: | | ||
source poky/oe-init-build-env build | ||
echo 'BAREBOX_CONFIG = "efi_defconfig"' >> conf/local.conf | ||
bitbake barebox | ||
- name: Build genimage, genimage-native | ||
run: | | ||
source poky/oe-init-build-env build | ||
bitbake genimage genimage-native | ||
- name: Build dt-utils | ||
run: | | ||
source poky/oe-init-build-env build | ||
bitbake dt-utils | ||
- name: Build microcom | ||
run: | | ||
source poky/oe-init-build-env build | ||
bitbake microcom | ||
- name: Cache Data | ||
env: | ||
CACHE_KEY: ${{ secrets.YOCTO_CACHE_KEY }} | ||
if: ${{ env.CACHE_KEY }} | ||
run: | | ||
mkdir -p ~/.ssh | ||
echo "$CACHE_KEY" >> ~/.ssh/id_ed25519 | ||
chmod 600 ~/.ssh/id_ed25519 | ||
rsync -rvx --ignore-existing build/downloads yocto-cache: || true | ||
rsync -rvx --ignore-existing build/sstate-cache yocto-cache: || true |
This file was deleted.
Oops, something went wrong.