Skip to content

Commit

Permalink
media-sound/ladish: Update live ebuild to current upstream (#551)
Browse files Browse the repository at this point in the history
  • Loading branch information
audiodef authored Aug 19, 2023
2 parents 1cc17ad + 8bf0356 commit 55b5495
Show file tree
Hide file tree
Showing 7 changed files with 106 additions and 55 deletions.
1 change: 1 addition & 0 deletions dev-libs/cdbus/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST cdbus-1.0_pre20230703.gh.tar.gz 169623 BLAKE2B 2fc57a83dea700d125220c0a6fd4fc4e76261f0fb3afb765233cd39bb303d31ae1e17204d47d910a8766dc223b288e44c456236ad7ee86836224107095b75391 SHA512 495b9a75d3b9615ec0b40308c707c527345b42034e7182b90cf59a4e0d72418480e667666706a3248ca5f9519606317af200e97ac2ec70d2925e829b907da9dc
45 changes: 45 additions & 0 deletions dev-libs/cdbus/cdbus-1.0_pre20230703.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{10..11} )
PYTHON_REQ_USE="threads(+)"
inherit python-any-r1 waf-utils

DESCRIPTION="libdbus helper library"
HOMEPAGE="https://github.com/LADI/cdbus"
if [[ "${PV}" == "9999" ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/LADI/cdbus.git"
EGIT_BRANCH="main"
else
CDBUS_COMMIT="32cb2e2519e4088421f2de1b2d46003d1cac6d6c"
SRC_URI="https://github.com/LADI/cdbus/archive/${CDBUS_COMMIT}.tar.gz -> ${P}.gh.tar.gz"
KEYWORDS="~amd64"
S="${WORKDIR}/${PN}-${CDBUS_COMMIT}"
fi

LICENSE="GPL-2 || ( GPL-2 AFL-2.1 )"
SLOT="0"

DEPEND="
sys-apps/dbus
"
RDEPEND="${DEPEND}"
BDEPEND="
virtual/pkgconfig
${PYTHON_DEPS}
"

src_prepare() {
rm -rf ".git" || die "Failed to remove git dir"
default
}

src_install() {
waf-utils_src_install

find "${ED}" \( -iname "gpl*.txt*" -o -iname "afl*.txt*" \) -delete || die
}
45 changes: 45 additions & 0 deletions dev-libs/cdbus/cdbus-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{10..11} )
PYTHON_REQ_USE="threads(+)"
inherit python-any-r1 waf-utils

DESCRIPTION="libdbus helper library"
HOMEPAGE="https://github.com/LADI/cdbus"
if [[ "${PV}" == "9999" ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/LADI/cdbus.git"
EGIT_BRANCH="main"
else
CDBUS_COMMIT=""
SRC_URI="https://github.com/LADI/cdbus/archive/${CDBUS_COMMIT}.tar.gz -> ${P}.gh.tar.gz"
KEYWORDS="~amd64"
S="${WORKDIR}/${PN}-${CDBUS_COMMIT}"
fi

LICENSE="GPL-2 || ( GPL-2 AFL-2.1 )"
SLOT="0"

DEPEND="
sys-apps/dbus
"
RDEPEND="${DEPEND}"
BDEPEND="
virtual/pkgconfig
${PYTHON_DEPS}
"

src_prepare() {
rm -rf ".git" || die "Failed to remove git dir"
default
}

src_install() {
waf-utils_src_install

find "${ED}" \( -iname "gpl*.txt*" -o -iname "afl*.txt*" \) -delete || die
}
11 changes: 11 additions & 0 deletions dev-libs/cdbus/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Adrian Schollmeyer</name>
</maintainer>
<upstream>
<remote-id type="github">LADI/cdbus</remote-id>
</upstream>
</pkgmetadata>
47 changes: 0 additions & 47 deletions media-sound/ladish/files/ladish-9999-disable-gladish.patch

This file was deleted.

4 changes: 2 additions & 2 deletions media-sound/ladish/ladish-1-r2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -13,12 +13,11 @@ HOMEPAGE="https://ladish.org"
if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://git.nedk.org/lad/ladish.git"
KEYWORDS=""
EGIT_SUBMODULES=()
else
inherit vcs-snapshot
SRC_URI="https://github.com/LADI/ladish/archive/${P}.tar.gz
https://git.nedk.org/lad/ladish.git/plain/waf?id=f15b80e6394ba0cbb4b76aa1b32071bfb971a8fa -> ${P}-waf-2.0.22"
https://gitea.ladish.org/LADI/ladish/raw/commit/30994438a1363306f00078a5791202cc4a73151f/waf -> ${P}-waf-2.0.22"
KEYWORDS="~amd64"
fi
LICENSE="GPL-2"
Expand All @@ -36,6 +35,7 @@ RDEPEND="media-libs/alsa-lib
${PYTHON_DEPS}"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )
dev-util/intltool
virtual/pkgconfig"

DOCS=( AUTHORS README NEWS )
Expand Down
8 changes: 2 additions & 6 deletions media-sound/ladish/ladish-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -28,6 +28,7 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="media-libs/alsa-lib
media-sound/jack2[dbus]
sys-apps/dbus
dev-libs/cdbus
dev-libs/expat
lash? ( !media-sound/lash )
${PYTHON_DEPS}"
Expand All @@ -39,16 +40,11 @@ BDEPEND="
doc? ( app-doc/doxygen )
"

DOCS=( AUTHORS README NEWS )

PATCHES=(
"${FILESDIR}/${P}-disable-gladish.patch"
)

QA_SONAME=( ".*/libalsapid.so" )

src_prepare()
{
rm -rf ".git" || die "Failed to remove git dir"
sed -i -e "s/RELEASE = False/RELEASE = True/" wscript
append-cxxflags '-std=c++11'
default
Expand Down

0 comments on commit 55b5495

Please sign in to comment.