Skip to content

Commit

Permalink
mail-client/sylpheed: enable SNI for TLS 1.3
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/697460
Package-Manager: Portage-2.3.103, Repoman-2.3.23
Signed-off-by: Akinori Hattori <[email protected]>
  • Loading branch information
hattya committed Aug 11, 2020
1 parent 61aa14b commit 8655bf0
Show file tree
Hide file tree
Showing 2 changed files with 18 additions and 0 deletions.
17 changes: 17 additions & 0 deletions mail-client/sylpheed/files/sylpheed-tls-1.3.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,17 @@
https://sylpheed.sraoss.jp/redmine/issues/306

Author: Antonio Ospite <[email protected]>

--- a/libsylph/ssl.c
+++ b/libsylph/ssl.c
@@ -262,6 +262,10 @@ gboolean ssl_init_socket_with_method(SockInfo *sockinfo, SSLMethod method)
return FALSE;
}

+#ifdef SSL_CTRL_SET_TLSEXT_HOSTNAME
+ SSL_set_tlsext_host_name(sockinfo->ssl, sockinfo->hostname);
+#endif
+
SSL_set_fd(sockinfo->ssl, sockinfo->sock);
while ((ret = SSL_connect(sockinfo->ssl)) != 1) {
err = SSL_get_error(sockinfo->ssl, ret);
1 change: 1 addition & 0 deletions mail-client/sylpheed/sylpheed-3.7.0-r1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -35,6 +35,7 @@ DEPEND="${CDEPEND}
xface? ( media-libs/compface )"
BDEPEND="virtual/pkgconfig"

PATCHES=( "${FILESDIR}"/${PN}-tls-1.3.patch )
DOCS="AUTHORS ChangeLog* NEW* PLUGIN* README* TODO*"

src_configure() {
Expand Down

0 comments on commit 8655bf0

Please sign in to comment.