Skip to content

Commit

Permalink
math/libxlsxwriter: Improve port and switch to CMake
Browse files Browse the repository at this point in the history
* Switch to CMake
* Enable "make test"
* Unbundle libs (md5 and minizip)
* Import upstreamed PR #454

Reference:
jmcnamara/libxlsxwriter#454

PR:		281018
Reviewed by:	bapt (maintainer)
  • Loading branch information
Daniel Engberg authored and Daniel Engberg committed Aug 31, 2024
1 parent 3a4b5f4 commit b2bbc1b
Show file tree
Hide file tree
Showing 4 changed files with 24 additions and 22 deletions.
25 changes: 21 additions & 4 deletions math/libxlsxwriter/Makefile
Original file line number Diff line number Diff line change
@@ -1,19 +1,36 @@
PORTNAME= libxlsxwriter
PORTVERSION= 1.1.8
DISTVERSIONPREFIX= v
DISTVERSION= 1.1.8
PORTREVISION= 1
CATEGORIES= math devel

PATCH_SITES= https://github.com/jmcnamara/libxlsxwriter/commit/
PATCHFILES= 5af9c1fd3e330a6a4aeaba58599e2c5294c521ab.patch:-p1

MAINTAINER= [email protected]
COMMENT= C library for creating Excel XLSX files
WWW= https://libxlsxwriter.github.io/

LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/License.txt

TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR}

USES= cmake:testing compiler:c11 localbase:ldflags minizip pathfix \
pkgconfig python:test ssl
USE_LDCONFIG= yes

USE_GITHUB= yes
GH_ACCOUNT= jmcnamara
MAKE_ARGS= INSTALL_DIR=${STAGEDIR}${PREFIX}

USE_LDCONFIG= yes
USES= compiler:c11 gmake
EXTRACT_AFTER_ARGS= --exclude ${GH_PROJECT_DEFAULT}-${GH_TAGNAME_EXTRACT}/third_party/md5 \
--exclude ${GH_PROJECT_DEFAULT}-${GH_TAGNAME_EXTRACT}/third_party/minizip \
--no-same-owner --no-same-permissions

CMAKE_TESTING_ON= BUILD_TESTS

CMAKE_ON= BUILD_SHARED_LIBS \
USE_OPENSSL_MD5 \
USE_SYSTEM_MINIZIP

.include <bsd.port.mk>
4 changes: 3 additions & 1 deletion math/libxlsxwriter/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,5 @@
TIMESTAMP = 1724058226
TIMESTAMP = 1725056181
SHA256 (jmcnamara-libxlsxwriter-v1.1.8_GH0.tar.gz) = 122c98353e5b69284a1cd782be7ae67bdefde2146f8197ef89a1aaf886058e86
SIZE (jmcnamara-libxlsxwriter-v1.1.8_GH0.tar.gz) = 21840785
SHA256 (5af9c1fd3e330a6a4aeaba58599e2c5294c521ab.patch) = b5b9d12c52bb6640c5399967360f9d1cd7a31a7c15bd2a6d3226d8c50b445074
SIZE (5af9c1fd3e330a6a4aeaba58599e2c5294c521ab.patch) = 3271
16 changes: 0 additions & 16 deletions math/libxlsxwriter/files/patch-src_Makefile

This file was deleted.

1 change: 0 additions & 1 deletion math/libxlsxwriter/pkg-plist
Original file line number Diff line number Diff line change
Expand Up @@ -33,7 +33,6 @@ include/xlsxwriter/vml.h
include/xlsxwriter/workbook.h
include/xlsxwriter/worksheet.h
include/xlsxwriter/xmlwriter.h
lib/libxlsxwriter.a
lib/libxlsxwriter.so
lib/libxlsxwriter.so.7
libdata/pkgconfig/xlsxwriter.pc

0 comments on commit b2bbc1b

Please sign in to comment.