Skip to content

Commit

Permalink
PACKAGE: bumpup ver. & optimize libretro-mame2003 & mame2003-plus (
Browse files Browse the repository at this point in the history
…#145)

* PACKAGE: bump libretro-mame2003 version

commit b6c6d52d8d630d1a172b6b771443dcbbdb45b76d

* PACKAGE-mame2003: add optimization patches

* PACKAGE: bump libretro-mame2003-plus version

commit 0fcccae96eb722d58be329977eb49173c5c97981

* PACKAGE-mame2003-plus: add optimization patches & fix cyclone
  • Loading branch information
Apaczer authored Jan 24, 2025
1 parent 28019c4 commit ca53a51
Show file tree
Hide file tree
Showing 9 changed files with 1,286 additions and 6 deletions.

Large diffs are not rendered by default.

Original file line number Diff line number Diff line change
@@ -0,0 +1,33 @@
From 7a95dce5273fafef97b28817e604f8541d25dd1a Mon Sep 17 00:00:00 2001
From: Apaczer <[email protected]>
Date: Sun, 19 Jan 2025 20:41:15 +0100
Subject: [PATCH 2/3] (MIYOO) Makefile: USE_CYCLONE & USE_DRZ80

also `-fno-PIC`
---
Makefile | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)

diff --git a/Makefile b/Makefile
index 71a3bbcb..80d1c135 100644
--- a/Makefile
+++ b/Makefile
@@ -522,11 +522,14 @@ else ifeq ($(platform), miyoo)
CC = /opt/miyoo/usr/bin/arm-linux-gcc
CXX = /opt/miyoo/usr/bin/arm-linux-g++
AR = /opt/miyoo/usr/bin/arm-linux-ar
- fpic := -fPIC
+ fpic := -fno-PIC
LDFLAGS += -shared -Wl,--version-script=link.T -Wl,-no-undefined
PLATCFLAGS := -DNO_UNALIGNED_ACCESS
PLATCFLAGS += -fomit-frame-pointer -march=armv5te -mtune=arm926ej-s -ffast-math
CXXFLAGS += -fno-rtti -fno-exceptions
+ ARM = 1
+ USE_CYCLONE := 1
+ USE_DRZ80 := 1

# Emscripten
else ifeq ($(platform), emscripten)
--
2.45.2.windows.1

Original file line number Diff line number Diff line change
@@ -0,0 +1,53 @@
From b59d9aaa7651d0ec82b4ea31abc641ed0704272b Mon Sep 17 00:00:00 2001
From: Apaczer <[email protected]>
Date: Sun, 19 Jan 2025 22:20:51 +0100
Subject: [PATCH 3/3] core_options: default "Cyclone+DrZ80(snd)" and "auto"
frameskip

---
src/mame2003/core_options.c | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/src/mame2003/core_options.c b/src/mame2003/core_options.c
index fdeb2466..38424ad1 100644
--- a/src/mame2003/core_options.c
+++ b/src/mame2003/core_options.c
@@ -635,7 +635,7 @@ static struct retro_core_option_v2_definition option_def_frameskip = {
{ "auto_max", "auto max" },
{ NULL, NULL },
},
- "disabled"
+ "auto"
};

static struct retro_core_option_v2_definition option_def_core_sys_subfolder = {
@@ -759,7 +759,7 @@ static struct retro_core_option_v2_definition option_def_cyclone_mode = {
NULL,
NULL,
{
- { "default", NULL },
+ { "available", NULL },
{ "disabled", NULL },
{ "Cyclone", NULL },
{ "DrZ80", NULL },
@@ -768,7 +768,7 @@ static struct retro_core_option_v2_definition option_def_cyclone_mode = {
{ "Cyclone+DrZ80(snd)", NULL },
{ NULL, NULL },
},
- "default"
+ "Cyclone+DrZ80(snd)"
};

static struct retro_core_option_v2_definition option_def_override_ad_stick = {
@@ -1270,7 +1270,7 @@ void update_variables(bool first_time)

#if (HAS_CYCLONE || HAS_DRZ80)
case OPT_CYCLONE_MODE:
- if(strcmp(var.value, "default") == 0)
+ if(strcmp(var.value, "available") == 0)
options.cyclone_mode = 6;
else if(strcmp(var.value, "Cyclone") == 0)
options.cyclone_mode = 1;
--
2.45.2.windows.1

Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
# Locally calculated
sha256 e4fc00c64bdb09aa1c1f4d6e30b0b1226ea4e942075e5fd8d7577604bc752ac0 libretro-mame2003-plus-6c413c298fcfb4dc7c8e8d6bec28c077d900e7dd.tar.gz
sha256 aae9f3027f5f4eea18a78b7f424690cb5a56cfad9be70f7463229a2cdfc1da08 libretro-mame2003-plus-0fcccae96eb722d58be329977eb49173c5c97981.tar.gz
Original file line number Diff line number Diff line change
Expand Up @@ -4,8 +4,8 @@
#
################################################################################

# Commit of 2023/09/12 - don't forget to regenerate arcade-dats flats file
LIBRETRO_MAME2003_PLUS_VERSION = 6c413c298fcfb4dc7c8e8d6bec28c077d900e7dd
# Commit of Jan 19, 2025 - don't forget to regenerate arcade-dats flats file
LIBRETRO_MAME2003_PLUS_VERSION = 0fcccae96eb722d58be329977eb49173c5c97981
LIBRETRO_MAME2003_PLUS_SITE = $(call github,libretro,mame2003-plus-libretro,$(LIBRETRO_MAME2003_PLUS_VERSION))
LIBRETRO_MAME2003_PLUS_LICENSE = MAME
LIBRETRO_MAME2003_PLUS_LICENSE_FILES = LICENSE.md
Expand Down
Original file line number Diff line number Diff line change
@@ -0,0 +1,33 @@
From 1fb6c36d34ba49b56e80eaec7020abf165a79914 Mon Sep 17 00:00:00 2001
From: Apaczer <[email protected]>
Date: Mon, 20 Jan 2025 20:27:08 +0100
Subject: [PATCH 1/2] (MIYOO) Makefile: USE_CYCLONE & USE_DRZ80

also `-fno-PIC`
---
Makefile | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)

diff --git a/Makefile b/Makefile
index 53680b6..c6bb102 100644
--- a/Makefile
+++ b/Makefile
@@ -519,11 +519,14 @@ else ifeq ($(platform), miyoo)
CC = /opt/miyoo/usr/bin/arm-linux-gcc
CXX = /opt/miyoo/usr/bin/arm-linux-g++
AR = /opt/miyoo/usr/bin/arm-linux-ar
- fpic := -fPIC
+ fpic := -fno-PIC
LDFLAGS += -shared -Wl,--version-script=link.T -Wl,-no-undefined
PLATCFLAGS := -DNO_UNALIGNED_ACCESS
PLATCFLAGS += -fomit-frame-pointer -march=armv5te -mtune=arm926ej-s -ffast-math
CXXFLAGS += -fno-rtti -fno-exceptions
+ ARM = 1
+ USE_CYCLONE := 1
+ USE_DRZ80 := 1

# Emscripten
else ifeq ($(platform), emscripten)
--
2.45.2.windows.1

Original file line number Diff line number Diff line change
@@ -0,0 +1,53 @@
From 5901108cbe57c5117ecfd8e016d303964ea17015 Mon Sep 17 00:00:00 2001
From: Apaczer <[email protected]>
Date: Mon, 20 Jan 2025 20:29:39 +0100
Subject: [PATCH 2/2] core_options: default "Cyclone+DrZ80(snd)" and "auto"
frameskip

---
src/mame2003/core_options.c | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/src/mame2003/core_options.c b/src/mame2003/core_options.c
index b94a7a6..900d4ec 100644
--- a/src/mame2003/core_options.c
+++ b/src/mame2003/core_options.c
@@ -597,7 +597,7 @@ static struct retro_core_option_v2_definition option_def_frameskip = {
{ "auto_max", "auto max" },
{ NULL, NULL },
},
- "disabled"
+ "auto"
};

static struct retro_core_option_v2_definition option_def_core_sys_subfolder = {
@@ -721,7 +721,7 @@ static struct retro_core_option_v2_definition option_def_cyclone_mode = {
NULL,
NULL,
{
- { "default", NULL },
+ { "available", NULL },
{ "disabled", NULL },
{ "Cyclone", NULL },
{ "DrZ80", NULL },
@@ -730,7 +730,7 @@ static struct retro_core_option_v2_definition option_def_cyclone_mode = {
{ "Cyclone+DrZ80(snd)", NULL },
{ NULL, NULL },
},
- "default"
+ "Cyclone+DrZ80(snd)"
};

static struct retro_core_option_v2_definition option_def_null = {
@@ -1210,7 +1210,7 @@ void update_variables(bool first_time)

#if (HAS_CYCLONE || HAS_DRZ80)
case OPT_CYCLONE_MODE:
- if(strcmp(var.value, "default") == 0)
+ if(strcmp(var.value, "available") == 0)
options.cyclone_mode = 1;
else if(strcmp(var.value, "Cyclone") == 0)
options.cyclone_mode = 2;
--
2.45.2.windows.1

Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
# Locally calculated
sha256 5709d156513d5f04b41c1c88fa2371647eb337d13d9cf10285a3c801671e4ca1 libretro-mame2003-105ca02fb85e92b9dd5d6ee43f7152d1199eb149.tar.gz
sha256 ff7f97b452fd2fb1716cd28a345aa01c9ddbcc72a9bc9670e2b697c8620e2871 libretro-mame2003-b6c6d52d8d630d1a172b6b771443dcbbdb45b76d.tar.gz
Original file line number Diff line number Diff line change
Expand Up @@ -4,8 +4,8 @@
#
################################################################################

# Commit of 2023/06/22
LIBRETRO_MAME2003_VERSION = 105ca02fb85e92b9dd5d6ee43f7152d1199eb149
# Commit of Dec 10, 2024
LIBRETRO_MAME2003_VERSION = b6c6d52d8d630d1a172b6b771443dcbbdb45b76d
LIBRETRO_MAME2003_SITE = $(call github,libretro,mame2003-libretro,$(LIBRETRO_MAME2003_VERSION))
LIBRETRO_MAME2003_LICENSE = MAME
LIBRETRO_MAME2003_LICENSE_FILES = LICENSE.md
Expand Down

0 comments on commit ca53a51

Please sign in to comment.