diff --git a/dev-libs/cdbus/Manifest b/dev-libs/cdbus/Manifest
new file mode 100644
index 00000000..8e13071d
--- /dev/null
+++ b/dev-libs/cdbus/Manifest
@@ -0,0 +1 @@
+DIST cdbus-1.0_pre20230703.gh.tar.gz 169623 BLAKE2B 2fc57a83dea700d125220c0a6fd4fc4e76261f0fb3afb765233cd39bb303d31ae1e17204d47d910a8766dc223b288e44c456236ad7ee86836224107095b75391 SHA512 495b9a75d3b9615ec0b40308c707c527345b42034e7182b90cf59a4e0d72418480e667666706a3248ca5f9519606317af200e97ac2ec70d2925e829b907da9dc
diff --git a/dev-libs/cdbus/cdbus-1.0_pre20230703.ebuild b/dev-libs/cdbus/cdbus-1.0_pre20230703.ebuild
new file mode 100644
index 00000000..d1789cf4
--- /dev/null
+++ b/dev-libs/cdbus/cdbus-1.0_pre20230703.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="threads(+)"
+inherit python-any-r1 waf-utils
+
+DESCRIPTION="libdbus helper library"
+HOMEPAGE="https://github.com/LADI/cdbus"
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/LADI/cdbus.git"
+ EGIT_BRANCH="main"
+else
+ CDBUS_COMMIT="32cb2e2519e4088421f2de1b2d46003d1cac6d6c"
+ SRC_URI="https://github.com/LADI/cdbus/archive/${CDBUS_COMMIT}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-${CDBUS_COMMIT}"
+fi
+
+LICENSE="GPL-2 || ( GPL-2 AFL-2.1 )"
+SLOT="0"
+
+DEPEND="
+ sys-apps/dbus
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+
+ ${PYTHON_DEPS}
+"
+
+src_prepare() {
+ rm -rf ".git" || die "Failed to remove git dir"
+ default
+}
+
+src_install() {
+ waf-utils_src_install
+
+ find "${ED}" \( -iname "gpl*.txt*" -o -iname "afl*.txt*" \) -delete || die
+}
diff --git a/dev-libs/cdbus/cdbus-9999.ebuild b/dev-libs/cdbus/cdbus-9999.ebuild
new file mode 100644
index 00000000..fe651d68
--- /dev/null
+++ b/dev-libs/cdbus/cdbus-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="threads(+)"
+inherit python-any-r1 waf-utils
+
+DESCRIPTION="libdbus helper library"
+HOMEPAGE="https://github.com/LADI/cdbus"
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/LADI/cdbus.git"
+ EGIT_BRANCH="main"
+else
+ CDBUS_COMMIT=""
+ SRC_URI="https://github.com/LADI/cdbus/archive/${CDBUS_COMMIT}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-${CDBUS_COMMIT}"
+fi
+
+LICENSE="GPL-2 || ( GPL-2 AFL-2.1 )"
+SLOT="0"
+
+DEPEND="
+ sys-apps/dbus
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+
+ ${PYTHON_DEPS}
+"
+
+src_prepare() {
+ rm -rf ".git" || die "Failed to remove git dir"
+ default
+}
+
+src_install() {
+ waf-utils_src_install
+
+ find "${ED}" \( -iname "gpl*.txt*" -o -iname "afl*.txt*" \) -delete || die
+}
diff --git a/dev-libs/cdbus/metadata.xml b/dev-libs/cdbus/metadata.xml
new file mode 100644
index 00000000..f47e5b5e
--- /dev/null
+++ b/dev-libs/cdbus/metadata.xml
@@ -0,0 +1,11 @@
+
+
+
+
+ nex+b-g-o@nexadn.de
+ Adrian Schollmeyer
+
+
+ LADI/cdbus
+
+
diff --git a/media-sound/ladish/files/ladish-9999-disable-gladish.patch b/media-sound/ladish/files/ladish-9999-disable-gladish.patch
deleted file mode 100644
index e308775e..00000000
--- a/media-sound/ladish/files/ladish-9999-disable-gladish.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From 8e9214859af07e6c13827d79e4f12e21386dcbd2 Mon Sep 17 00:00:00 2001
-From: Simon van der Veldt
-Date: Sat, 27 Feb 2021 13:28:40 +0100
-Subject: [PATCH] Disable gladish
-
----
- wscript | 17 +----------------
- 1 file changed, 1 insertion(+), 16 deletions(-)
-
-diff --git a/wscript b/wscript
-index 0ea49c44..bc3817e8 100644
---- a/wscript
-+++ b/wscript
-@@ -161,7 +161,7 @@ def configure(conf):
-
- conf.env['LIB_EXPAT'] = ['expat']
-
-- build_gui = True
-+ build_gui = False
-
- if build_gui and not conf.check_cfg(
- package = 'glib-2.0',
-@@ -648,21 +648,6 @@ def build(bld):
-
- bld.install_files('${PREFIX}/bin', 'ladish_control', chmod=0o0755)
-
-- # 'Desktop' file (menu entry, icon, etc)
-- bld.install_files('${PREFIX}/share/applications/', 'gui/gladish.desktop', chmod=0o0644)
--
-- # Icons
-- icon_sizes = ['16x16', '22x22', '24x24', '32x32', '48x48', '256x256']
-- for icon_size in icon_sizes:
-- bld.path.ant_glob('art/' + icon_size + '/apps/*.png')
-- bld.install_files('${PREFIX}/share/icons/hicolor/' + icon_size + '/apps/', 'art/' + icon_size + '/apps/gladish.png')
--
-- status_images = []
-- for status in ["down", "unloaded", "started", "stopped", "warning", "error"]:
-- status_images.append("art/status_" + status + ".png")
--
-- bld.install_files('${DATA_DIR}', status_images)
-- bld.install_files('${DATA_DIR}', "art/ladish-logo-128x128.png")
- bld.install_files('${DOCDIR}', ["AUTHORS", "README", "NEWS"])
- bld.install_as('${DATA_DIR}/COPYING', "gpl2.txt")
-
---
-2.26.2
-
diff --git a/media-sound/ladish/ladish-1-r2.ebuild b/media-sound/ladish/ladish-1-r2.ebuild
index 77119be1..7188f464 100644
--- a/media-sound/ladish/ladish-1-r2.ebuild
+++ b/media-sound/ladish/ladish-1-r2.ebuild
@@ -13,12 +13,11 @@ HOMEPAGE="https://ladish.org"
if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://git.nedk.org/lad/ladish.git"
- KEYWORDS=""
EGIT_SUBMODULES=()
else
inherit vcs-snapshot
SRC_URI="https://github.com/LADI/ladish/archive/${P}.tar.gz
- https://git.nedk.org/lad/ladish.git/plain/waf?id=f15b80e6394ba0cbb4b76aa1b32071bfb971a8fa -> ${P}-waf-2.0.22"
+ https://gitea.ladish.org/LADI/ladish/raw/commit/30994438a1363306f00078a5791202cc4a73151f/waf -> ${P}-waf-2.0.22"
KEYWORDS="~amd64"
fi
LICENSE="GPL-2"
@@ -36,6 +35,7 @@ RDEPEND="media-libs/alsa-lib
${PYTHON_DEPS}"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )
+ dev-util/intltool
virtual/pkgconfig"
DOCS=( AUTHORS README NEWS )
diff --git a/media-sound/ladish/ladish-9999.ebuild b/media-sound/ladish/ladish-9999.ebuild
index c01a96ac..77509db3 100644
--- a/media-sound/ladish/ladish-9999.ebuild
+++ b/media-sound/ladish/ladish-9999.ebuild
@@ -28,6 +28,7 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="media-libs/alsa-lib
media-sound/jack2[dbus]
sys-apps/dbus
+ dev-libs/cdbus
dev-libs/expat
lash? ( !media-sound/lash )
${PYTHON_DEPS}"
@@ -39,16 +40,11 @@ BDEPEND="
doc? ( app-doc/doxygen )
"
-DOCS=( AUTHORS README NEWS )
-
-PATCHES=(
- "${FILESDIR}/${P}-disable-gladish.patch"
-)
-
QA_SONAME=( ".*/libalsapid.so" )
src_prepare()
{
+ rm -rf ".git" || die "Failed to remove git dir"
sed -i -e "s/RELEASE = False/RELEASE = True/" wscript
append-cxxflags '-std=c++11'
default